Sign up Sign in Samples Blog contact support
Installation on Windows

Support Ticket

acknowledged
 
+issue

I tried to install Wagn following both options described in Download

Option A: Quick Start and Option B: Install via Git

but any worked. I got the message below. I tried many ways, but was the same.

card_builder.rb is at lib/util/, but seems that the machine don't find it when needed.

May you help me? My machine is running Rails 3.0.3 and ruby 1.9.2p136. Windows Vista is the OS.

Thank You very much.

+example

/c/wagn-1.5 (master)
$ rake wagn:create
(in c:/wagn-1.5)
rake aborted!
no such file to load -- lib/util/card_builder.rb
<internal:lib/rubygems/custom_require>:29:in `require'
<internal:lib/rubygems/custom_require>:29:in `require'
c:/wagn-1.5/vendor/rails/activesupport/lib/active_support/dependencies.rb:156:in `block in require'
c:/wagn-1.5/vendor/rails/activesupport/lib/active_support/dependencies.rb:521:in `new_constants_in'
c:/wagn-1.5/vendor/rails/activesupport/lib/active_support/dependencies.rb:156:in `require'
c:/wagn-1.5/lib/tasks/generate_fixtures.rake:1:in `<top (required)>'
c:/wagn-1.5/vendor/rails/activesupport/lib/active_support/dependencies.rb:145:in `load'
c:/wagn-1.5/vendor/rails/activesupport/lib/active_support/dependencies.rb:145:in `block in load_with_new_cons
tant_marking'
c:/wagn-1.5/vendor/rails/activesupport/lib/active_support/dependencies.rb:521:in `new_constants_in'
c:/wagn-1.5/vendor/rails/activesupport/lib/active_support/dependencies.rb:145:in `load_with_new_constant_mark
ing'
c:/wagn-1.5/vendor/rails/railties/lib/tasks/rails.rb:9:in `block in <top (required)>'
c:/wagn-1.5/vendor/rails/railties/lib/tasks/rails.rb:9:in `each'
c:/wagn-1.5/vendor/rails/railties/lib/tasks/rails.rb:9:in `<top (required)>'
<internal:lib/rubygems/custom_require>:29:in `require'
<internal:lib/rubygems/custom_require>:29:in `require'
c:/wagn-1.5/Rakefile:10:in `<top (required)>'
c:/Ruby192/lib/ruby/1.9.1/rake.rb:2373:in `load'
c:/Ruby192/lib/ruby/1.9.1/rake.rb:2373:in `raw_load_rakefile'
c:/Ruby192/lib/ruby/1.9.1/rake.rb:2007:in `block in load_rakefile'
c:/Ruby192/lib/ruby/1.9.1/rake.rb:2058:in `standard_exception_handling'
c:/Ruby192/lib/ruby/1.9.1/rake.rb:2006:in `load_rakefile'
c:/Ruby192/lib/ruby/1.9.1/rake.rb:1991:in `run'
c:/Ruby192/bin/rake:31:in `<main>'

/c/wagn-1.5 (master)

 
+discussion

Wagn is not ready for Rails 3.0 yet. I'm running 2.3.5

 

Also make sure you initialize and update the git submodules


OK. Clarified my doubts. I'll try other way of build what I want. Thank you very much.

  --Fernando Bezerra Santa Rosa.....Sun Jan 02 12:51:29 -0800 2011


I apologize that the windows installation is still difficult. It's a high priority for us to address that. Thanks for letting us know about the issues you're seeing!

 

- Ethan

  --Ethan McCutchen.....Thu Jan 06 10:02:02 -0800 2011


Does Slavic's new code handle this? Should we ticket ease installation on Windows and tag it 1.5+3?

  --John Abbe.....Sun Feb 20 17:35:34 -0800 2011


I also have this problem Ruby 1.9.2 on Windows 7. Is there a fix or workaround for this?

  --Carlos S (Not signed in).....Mon Apr 11 19:34:04 -0700 2011


I don't think we've got a working fix yet. I don't have that environment available to me yet, but the first thing I would try is going to lib/tasks/generate_fixtures.rake and changing

 

require 'lib/util/card_builder.rb'

 

to

 

require "#{RAILS_ROOT}/lib/util/card_builder.rb"

  --Ethan McCutchen.....Mon Apr 11 19:41:20 -0700 2011