Sign up Sign in Samples Blog contact support
Older versions - Updating to a Gem Wagn

If your Wagn was NOT installed from a gem, then first check the Wagn version of your existing installation:

 

For version 1.10 through 1.12.6

 

  1. Create a new Wagn app using steps 1 and 2 from the installation section above.
  2. Copy config/database.yml from the old site to the new one.
  3. Copy the old local/files contents to the new files directory.
  4. If you have edited config/wagn.yml in your old site, make the corresponding changes to the new config/application.rb file.
  5. Follow the standard upgrade procedure above.

 

Upgrading pre-version 1.10

First update your Wagn to version 1.10 via the old update mechanisms, and then follow the directions above to then upgrade to the wagn gem.