Sign up Sign in Samples Blog contact support
Where is the captcha toggle?

Support Ticket

open
 
+issue

The docs on the site say there's a captcha toggle I can turn on for Sign Up, but I don't see one. Under Rules/Create the only options are Anyone, Administrator, Anyone Signed In.

+screenshot
186308 large
 
+discussion

We found it by sorting By Name and turned it on. Now I get an error that the ReCaptcha site key doesn't match. I'm guessing this is because we have to use the widget code that Google provided for us. The existing code probably has your site key in it.

 

Where is this code found?

--Lora Friedenthal.....2016-10-08 18:14:45 UTC

Can you please take a look at this? I'm sending out lots of spam emails without captcha in place and I don't know why it gets a server error when I turn the option on.

--Lora Friedenthal.....2016-10-19 11:16:19 UTC

*poke* I'd really like to stop sending out undeliverable mail, which isn't going to happen until I can stop bots from signing up...

--Lora Friedenthal.....2016-10-31 10:50:36 UTC

Sorry. Try the "*recaptcha settings" card.

--Ethan McCutchen.....2016-11-02 06:55:39 UTC

Okay, so I see that card has 3 components. Am I just supposed to Edit the public key and private key cards or am I supposed to interact with them in some other way to enter the info from google?

--Lora Friedenthal.....2016-11-02 11:37:47 UTC

Well. I tried that. I still get "error for site owner: invalid site key"

--Lora Friedenthal.....2016-11-02 11:50:11 UTC

There are two issues:

1) *recaptcha+public key and *recaptcha+private key have the wrong cardtype. By default they are "Basic" cards but they should be "Phrase" cards.

Go to edit > type for those cards, choose "Phrase" and remove the paragraph tags that were added to your keys because it were basic cards (a "< p>" at the beginning and a "< /p>" at the end)

2) the site has to be restarted (otherwise it keeps using the old keys)

 

Both issues will be fixed with the next release (probably coming next week)

--Philipp Kuehl.....2016-11-02 22:04:41 UTC

Thanks! Rebooting now.

 

Am I going to have to worry about updating all the Ruby stuff with the new version? Some things started to say that they were using deprecated versions, but when I tried to update to a new version of Ruby some of the dependencies failed and I just gave up trying fix linux stupidity.

--Lora Friedenthal.....2016-11-02 22:15:24 UTC

YAY! THAT WORKED!

--Lora Friedenthal.....2016-11-02 22:18:06 UTC

I think at some point next year we have to drop support for Ruby 1.9.3 but if you are above 2.0 you should be safe for a while.

--Philipp Kuehl.....2016-11-02 22:37:34 UTC