Sign up Sign in Samples Blog contact support
installation issues with mysql and rmagick

Support Ticket

answered
 
+issue

I seem to be having horrible issues installing wagn. The first is gem install. The gem does not exist. The next issue is downloading the ruby application and running it. This breaks on installing mysql2 and rmagick. I am running ruby 1.9.3. I also think it would be nice to install the gem into another ruby application.

 
+discussion

there is currently no wagn gem. wagn is itself a rails application and is not yet ready to include in other rails apps, but there are plans in the works.

 

You've probably already seen the standard installation docs. On that page there is a link to Installing Dependencies. They may be helpful in figuring out your mysql2 and rmagick issues. If not, I would consult the installation pages for those gems.

--Ethan McCutchen.....2013-08-10 16:22:43 +0000

On my running server I have ruby-1.9 and all the other as updated as CentOS 6 can be.

 

The issue with rmagick is normal since rmagick is not keeping up with the development of imagemagick.

wagn "should" use mini_magick e.g. or something else, OR you could downgrade imagemagick in order to use old rmagick.

 

Nonetheless I am running wagn without rmagick (outcommented in the Gemfile) and e.g. logo upload worked fine.

--nico.....2013-09-05 04:34:02 +0000

Are we talking gems (mini_magick vs. imagemagick)? One hint is to do 'gem install ' for gems that give you problems with bundle install. Gives better debugging info.

 

I think it may work to upload without rmagick, but it probably won't scale the images for different size options.

--Gerry Gleason.....2013-09-06 16:59:15 +0000