Sign up Sign in Samples Blog contact support
wagn 1.7 install fails for ruby-1.9.2 on OS X 10.6

Support Ticket

closed
 
+issue
During bundle install --without hosting mysql on OS X 10.6.7 (Snow Leopard) using a dedicated RVM gemset the following error occurs:
Installing rbx-require-relative (0.0.5) /Users/name/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/installer.rb:388:in `ensure_required_ruby_version_met': rbx-require-relative requires Ruby version ~> 1.8.7. (Gem::InstallError)
  from /Users/name/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/installer.rb:156:in `install'
  from /Users/name/.rvm/gems/ruby-1.9.2-p290@polypath/gems/bundler-1.0.18/lib/bundler/source.rb:101:in `block in install'
   from /Users/name/.rvm/gems/ruby-1.9.2-p290@polypath/gems/bundler-1.0.18/lib/bundler/rubygems_integration.rb:78:in `preserve_paths'
  from /Users/name/.rvm/gems/ruby-1.9.2-p290@polypath/gems/bundler-1.0.18/lib/bundler/source.rb:91:in `install'
  from /Users/name/.rvm/gems/ruby-1.9.2-p290@polypath/gems/bundler-1.0.18/lib/bundler/installer.rb:58:in `block (2 levels) in run'
  from /Users/name/.rvm/gems/ruby-1.9.2-p290@polypath/gems/bundler-1.0.18/lib/bundler/rubygems_integration.rb:93:in `with_build_args'
  from /Users/name/.rvm/gems/ruby-1.9.2-p290@polypath/gems/bundler-1.0.18/lib/bundler/installer.rb:57:in `block in run'
  from /Users/name/.rvm/gems/ruby-1.9.2-p290@polypath/gems/bundler-1.0.18/lib/bundler/installer.rb:49:in `run'
  from /Users/name/.rvm/gems/ruby-1.9.2-p290@polypath/gems/bundler-1.0.18/lib/bundler/installer.rb:8:in `install'
  from /Users/name/.rvm/gems/ruby-1.9.2-p290@polypath/gems/bundler-1.0.18/lib/bundler/cli.rb:220:in `install'
  from /Users/name/.rvm/gems/ruby-1.9.2-p290@polypath/gems/bundler-1.0.18/lib/bundler/vendor/thor/task.rb:22:in `run'
  from /Users/name/.rvm/gems/ruby-1.9.2-p290@polypath/gems/bundler-1.0.18/lib/bundler/vendor/thor/invocation.rb:118:in `invoke_task'
  from /Users/name/.rvm/gems/ruby-1.9.2-p290@polypath/gems/bundler-1.0.18/lib/bundler/vendor/thor.rb:263:in `dispatch'
  from /Users/name/.rvm/gems/ruby-1.9.2-p290@polypath/gems/bundler-1.0.18/lib/bundler/vendor/thor/base.rb:386:in `start'
  from /Users/name/.rvm/gems/ruby-1.9.2-p290@polypath/gems/bundler-1.0.18/bin/bundle:13:in `'
  from /Users/name/.rvm/gems/ruby-1.9.2-p290@polypath/bin/bundle:19:in `load' from /Users/name/.rvm/gems/ruby-1.9.2-p290@polypath/bin/bundle:19:in `'
 
+discussion

we've worked through almost all the bugs for ruby 1.9 and are hoping to release a 1.9 compatible version with Wagn 1.7.2.  But it's not there just yet.  Currently works well with ruby 1.8.6 or 1.8.7. 


wagn 1.8 fully supports ruby 1.9.x

  --Ethan McCutchen.....Fri Mar 23 21:46:56 +0000 2012


(closing)

  --Ethan McCutchen.....Fri Mar 23 21:47:04 +0000 2012